Ik gebruik de Automatische Updater niet

Om mijn PHP forum te upgraden naar de nieuwste versie van phpBB, gebruik ik de automatische updater NIET meer.
Al in versie 3.1 x kreeg je bij gebruik van het upgradepakket te maken met het installeren van extra te downloaden bestanden.
Om die extra bestanden te installeren, diende je secuur te werk gaan, anders loop je de kans dat er problemen ontstaan en het forum ontoegankelijk wordt.
Wat thans ook wel gebeurt, is dat er een vervelende timeout kan ontstaan bij het upgraden.....

Daarom ben ik bij een upgrade overgestapt op het downloaden van het complete installatiepakket.
Echter, gebruik dat pakket niet zomaar - want dat zou betekenen dat het bestaande forum vernietigd wordt voor een nieuw op te starten forum.

Met het volledige installatiepakket dien je eerst voorbereidend werk te gaan verrichten - zowel op de server als met het door jouw uitgepakte installatiepakket.

Vooraleer jij aan de slag gaat jouw forum te gaan upgraden, dien je ingelogd te zijn en in het Beheerderspaneel via Foruminstellingen prosilver als standaard te gebruiken thema te hebben ingesteld.

Het uitgepakte installatie bestand voorbereiden:

Klik de mappen open totdat je bij alle forumbestanden aankomt.
Verwijder nu uit deze mappen en bestanden de volgende onderdelen:


  • het bestand config.php
  • de map files/
  • de map images/
  • de map store/
* indien op de server de .htacces aangevuld is:
  • het betand .htaccess ook verwijderen!​



Op de server inloggen en daar het volgende doen:

verwijder daar alle bestanden, behalve die hieronder vermeld staan:


  • het bestand config.php
  • indien aangevuld, het bestand .htaccess
  • de map ext/
  • de map files/
  • de map images/
  • de map store/
  • de map styles


Zijn de voorbereiding gereed gekomen - dan wordt het zaak de upgrade bestanden naar jou server te uploaden.

Is dat gebeurd, dan pal achter jouw forumlink /install typen.
In mijn geval is dat spaceship-aarde.nl/install.

Als alles goed gaat wordt de database geupdated (duurt niet lang) en daarna kan je inloggen in de ACP = Beheerderspaneel.

Op de server verwijder je de map install - anders geeft het forum een foutmelding.

Indien om onbegrijpelijke redenen het Beheerspaneel aangeeft dat de forumversie na de upgrade verouderd is, herhaal dan bovenstaande, maar dan met het installatiepakket wat je hier weghaalt: phpBB • Download phpBB 3.2

Download het pakket en pak het uit.

Kopieer nu uit het vorige installatie pakket uit de map language de map nl en plak deze map vervolgens in het nieuwe installatiebestand in de map language erbij.

Herhaal nu de voorbereidingen in het nieuwe installatiebestand en op de server.

Is alles weer conform de hierboven beschreven handelingen afgehandeld, dan wederom de installatie opstarten.
Is alles op rolletjes gegaan, zal daarna de ACP aangeven dat jouw forum de nieuwste phpBB versie bevat.
 

Abraham54

Beheer
Team lid
Lid geworden
2 aug 2016
Berichten
23.373
Reactiescore
5.993
Punten
713
Leeftijd
67
OS
Windows 10 Professional x64
AV
Ziggo F-Secure antivirus
FW
ZoneAlarm Free Firewall
Of het nu direct achter jouw domein of achter admin /install
Doe je dat niet of niet goed, dan komt er niet de phpBB install venster.
 

Black Tiger

Moderator
Team lid
Lid geworden
6 aug 2018
Berichten
4.757
Reactiescore
1.134
Punten
468
Locatie
State Penitentiary
Website
www.satellitefun.org
OS
Windows 10 Pro
AV
AVG
FW
Windows Firewall
Ter verduidelijking, het klinkt misschien raar omdat "install" eigenlijk installatie betekent. Maar in veel forum software en zeker phpBB wordt vanuit de install directory de installatie of de upgrade gedaan afhankelijk van wat er nodig is.
Dus dat is een normale situatie.
 

toska

Bekend Lid
Lid geworden
28 aug 2016
Berichten
2.167
Reactiescore
235
Punten
193
Leeftijd
58
Locatie
belgie
Website
www.games4you.be
OS
Windows 10
AV
norton internet security 2021
FW
norton firrewal
Of het nu direct achter jouw domein of achter admin /install
Doe je dat niet of niet goed, dan komt er niet de phpBB install venster.
moet je dat zelf doen of gebeurt dat automatisch??
 

Maxstar

VIP Security Analist
Lid geworden
6 feb 2020
Berichten
149
Reactiescore
62
Punten
28
Leeftijd
39
Locatie
Root
Website
www.pcwebplus.nl
OS
Windows 10
AV
Emsisoft Anti-Malware
Ter info: check bij een update ook even ../public_html/phpbb-directory/store/ via FTP.

Is daar het bestand io_lock.lock aanwezig, die eerst verwijderen. Anders krijg je een foutmelding bij het updateproces.

601ecc30c80c5-lock-file.png
 

Abraham54

Beheer
Team lid
Lid geworden
2 aug 2016
Berichten
23.373
Reactiescore
5.993
Punten
713
Leeftijd
67
OS
Windows 10 Professional x64
AV
Ziggo F-Secure antivirus
FW
ZoneAlarm Free Firewall
@Maxstar - is dat nieuw - ben even ingelogd via FTP op mijn vorige phpBB forum en inderdaad, dat bestand zit in de store.
 

Maxstar

VIP Security Analist
Lid geworden
6 feb 2020
Berichten
149
Reactiescore
62
Punten
28
Leeftijd
39
Locatie
Root
Website
www.pcwebplus.nl
OS
Windows 10
AV
Emsisoft Anti-Malware
Sinds 3.2.0 blijven de volgende bestanden en/of mappen soms achter die een nieuwe update in de weg zitten.

../public_html/forum/cache/installer -> map
../public_html/phpbb-directory/store/install_config.php
../public_html/phpbb-directory/store/io.lock

Waardoor dit komt kan ik niet verklaren, misschien heeft dit te maken met de settings van Installatron in Direct Admin? Zelf laat ik Installatron niets - automatisch - (meer) updaten.

601ed29c2da8e-6018568069c33-HJT2.jpg
 

Abraham54

Beheer
Team lid
Lid geworden
2 aug 2016
Berichten
23.373
Reactiescore
5.993
Punten
713
Leeftijd
67
OS
Windows 10 Professional x64
AV
Ziggo F-Secure antivirus
FW
ZoneAlarm Free Firewall
Ik heb mijn phpBB forum geupgrade naar phpBB 3.3.3 en de io.lock.lock heeft niet voor problemen gezorgd.
 
Bovenaan Onderaan